Error "Code Purple" al utilizar la Recuperación en ordenadores HP

Recuerda: Si este artículo no soluciona tu problema, o tienes dudas a la hora de su aplicación, puedes publicar un nuevo tema en el foro y resolveremos tu incidencia de forma personalizada.
Y si el artículo ha solucionado tu problema y te ha resultado de utilidad, háznoslo saber compartiéndolo en redes sociales. Sólo te llevará unos segundos.

Descripción: 

Puede aparecer una ventana de error al realizar el proceso de recuperación (recovery) en ordenadores HP, con un contenido similar al siguiente:

Error de configuración del sistema. Su sistema ha detectado un error de configuración...A menos que se corrija el error, su PC no funcionará como es debido. Apague su PC pulsando por un momento el botón de encendido y apagado....(Code Purple).

Causa: 

Esto se produce por un problema en la verificación que realiza el proceso, para comprobar que se está utilizando el proceso de recuperación adecuado al equipo en que se está ejecutando. Si la recuperación detecta que la información DMI de la placa no se corresponde con la que debiera, el proceso se detiene por seguridad. Puede ocurrir porque se haya corrompido la información DMI en la placa base, porque se haya sustituido la placa base, o porque se haya dañado algún fichero en el sistema de recuperación.

Dificultad: 
Intermedio
Solución: 

La solución consiste en arrancar el equipo con un disco de arranque (Linux o Windows) y eliminar la carpeta c:\hp\bin\CheckDMI. A partir de ahi, se puede reiniciar el equipo, y el asistente de recuperación seguirá ejecutándose con normalidad.

Se aplica a: 
Windows XP 32 bits
Windows XP 64 bits
Windows Vista 32 bits
Windows Vista 64 bits
Windows 7 32 bits
Windows 7 64 bits